SecuritySpy Won't Stay Awake Overnight
  • Running SecuritySpy v3.4 (not sure if this is the latest version or not) on my Mac Book Pro under Yosemite 10.10. Previously had been running the same application under Mavericks. Love the software. It's great. Runs fine under Mavericks, and now runs fine in Yosemite.

    One problem. I need SecuritySpy to remain running 24/7 as it's an integral part of our security system and I need to get motion detection email notifications. All of this works while SS is running, but overnight inevitably "something" is sleeping. Not sure if it's SS, or the OS system, etc. Same issue in Mavericks as in Yosemite, so that's not a factor.

    So far I've set all the Sys Pref settings to never sleep, no screen saver, no put hard drive to sleep, checked the "do not nap" box for SS, and even tried running Caffeine to no avail.

    After so many hours (maybe 8-10 or so, don't know as I'm asleep) the SS or the computer is not staying active and awake. The screen is black, then if I hit any key SS immediately appears but with all blue screens for about five seconds, then displays all the normal images.

    Next I'll try running the Terminal command:      launchctl submit -l noidle -- `which pmset` noidle

    . . . you have to leave Terminal running for this to work, but ostensibly this is what "Caffeine" does anyway, so doubt this will solve my issue.

    ANY ideas or suggestions greatly appreciated.

    Thanking you in advance, I am . . .

    John
    Ocean City, NJ
    Long time user of Security Spy. Several registered licenses.

  • Hi John,

    Glad you like the software!

    This could be due to the "App Nap" feature of recent OS X versions putting SecuritySpy to sleep. SecuritySpy does attempt to disable this feature, so I'm not sure why it doesn't seem to be working for you. We don't have any similar reports of this from other users.

    Still, the first thing to try is to download and install the latest version of SecuritySpy, which is later than the version you are currently using.

    Does this resolve the problem?

    If not, and you are using a WiFi network, can you test whether connecting your MacBook to your switch/router using wired ethernet prevents this from occurring?
  • Okay. I upgraded to the latest version of SecuritySpy and still experiencing the same problem.
    What log(s) can I look at to try to diagnose this?
    I know the exact "time" I woke the MBP, but have no idea of the file path(s) for look for some log info.
    Can you suggest where I should be looking, or any other possible culprit?
    The "don't nap" checkbox is checked.
    John
  • Hi John, I'm a bit at a loss here I'm afraid. This isn't a known problem and I can't imagine what could be causing it, if App Nap and computer sleep are both disabled. I know this is an obvious question, but are you physically closing the MacBook at any point?

    Also, with MacBooks, you will have separate settings in the Energy Saver window for when you are on battery vs. when you are on mains power - make sure you have disabled sleep mode for when the MacBook is connected to mains power (there should be a tab bar at the top with two options: Battery | Power Adapter).
  • Never close the display.
    Am aware of separate settings for battery vs. mains.
    Still Baffled.
    Where can I look for a log that might provide a clue?
  • Very strange.

    Open the Console (you'll find it within your /Applications/Utilities/ folder). Select the "All Messages" log on the left of the Console window and see if there is anything there about sleep. Normally any events that cause the Mac to sleep or wake will be shown here.
  • I "think" I may have found the culprit.
    Will report back tomorrow.
    Thank you for your patience.
    John
  • Okay. I found the problem and it was ENTIRELY my fault. I couldn't see the forrest from the trees, even after weeks of testing on various platforms, the "shut-down" always came back to one particular machine, my MBP. I have licenses for SecuritySpy on 3 separate machines so this helped out in pinning down at least that my problem was "computer specific.

    So, I dug a little deeper, beyond all the default screens for Energy Saver in Sys Prefs, and even with Computer Sleep set to Never, and Put hard disks to sleep when possible Not Checked, and Display to Never Sleep, and running Caffeine, and issuing Terminal Commands, I neglected the "Schedule" button!

    Sure enough, I had long ago (and completely forgotten about it) set the MBP to sleep at 2PM every night, hence the MBP was not awake each morning when I checked on it!

    I deeply apologize to everyone who spent time on this helping me, and learned a lot through the process, and should have known to look at the "schedule" right away, but sometimes you can't see what's right in front of you.

    Having worked on PC's and MAC's for 30 years now I had fallen into the trap of searching for a complex cause, only to discover something so simple.

    Again, thank you so very much for all the time and trouble everyone has invested on my behalf.

    I love SecuritySpy! Keep up the great work and the great support!

    All the best,

    John
  • Hi John,

    Mystery solved! That's great. I too should have thought of the schedule button. I will remember this for the future, as it will be useful if we encounter any other user experiencing the same problem.

    All the best,
    Ben
  • Thank you again Ben for your patience!
    John

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!