Problem view recordings via SecuritySpy 3.4's HTTPS webserver
  • Hi,

    Not sure if anyone else has seen this. Upgraded to the latest version of SecuritySpy (3.4). Was excited to see that it now has a built in HTTPS web server. I had configured the Mac in the past provide an SSL connection via the its apache webserver and the redirect features.

    The new version works great for all the web features running over its internal HTTPS server. Menus, live video feeds, etc. However, when you select a video clip for playback, it pulls the 1st few seconds and then there is a long (can be several minutes) pause before it downloads the remaining footage.

    Does not happen if accessing through the non-encrypted connection (HTTP). Nor does it happen if I go back to the old redirect method required on previous versions.

    It is like it is processing something before it returns the remaining video clip. I have tried different browsers, internal and external to my home. Does not seem to alter the behavior.

    Running on 10.9.4 Mac mini 2.6Ghz 16MB RAM. Dedicated to securityspy, so nothing else running.

    Any suggestion on diagnostics? I did turn off the Mac's webserver to see if that was conflicting as well.

    Thanks,

    Eric
  • Hi Eric, this is a strange one, we can't reproduce it here and no other users have reported this. On our test server here, movies start playing as soon as I click on the links.

    Roughly how large are the movie files in question?

    Probably the best way to investigate this problem would be for you to allow us temporary access to your server via the HTTPS connection so that we can test it from our end. If this is possible, please email us the details and we'll look into it.

    Thanks.
  • Hi Ben,

    Movies sizes range from 0.18M to upwards of 13M. Depends on length of motion detection recording.

    I am sending an email with the details as you suggested. Thanks.

    Eric
  • Hello, I'm experiencing the same issue. I am not able to view the videos in web interface or remote patrol on 3.4.1 when using HTTPS. HTTP works fine.

    Please advise. thanks.
  • I also have the same same symptoms that Mr_C described. I'm not able to view captured videos through the https port provided by Security Spy. I downloads 10% of a captured video and then hangs for a really long time. This occurs whether I'm accessing it locally through localhost or remotely from work.

    If I proxy https through nginx to Security Spy's http port I can view videos through the web interface without problem.

    However, even through nginx I still can't view any captured videos with remote patrol (iPhone or HD versions) unless I use http. I'm not sure the symptoms are identical so this might be a completely different problem than the web interface.

    For the web interface I'm using Chrome 36.0.1985.143. For my iPhone 4s I'm on version 7.1. On my iPad I have 7.1.2 (I tested both the iPhone and HD versions of Remote Patrol).
  • There are two separate issues here: one is HTTPS in Remote Patrol (and iOS in general). Unfortunately Apple has made it rather difficult to display movies from HTTPS servers with self-signed certificates. The solution here is to purchase and install an official certificate for SecuritySpy. Fortunately, this is quite easy and inexpensive.

    The second issue is unusually slow data transfer for movies over HTTPS to Mac web browsers, which is the original issue outlined above. This is a strange one because we've only had a few reports of this, and we're struggling to reproduce the issue here. We're still looking into this and hope to have a solution soon.
  • Hi Ben,

    Thanks for the info. I installed an official certificate per your instructions (thanks for approving it so quickly) and I was able to reproduce the same symptoms on Remote Patrol (hanging after loading a portion of the video).

    I then used the same certificate with nginx and now both the web page and Remote Patrol are working great for viewing captured videos.

    I'm fine with this setup so a fix is not urgent for me.

    If you're looking for any clues to reproduce the problem I'm using a Mac Mini with a 2.3 GHz Intel Core i7 and 8 GB of memory running Mountain Lion OS X 10.8.5 (12F45). I have 9 cameras, 8 analog cameras split between two Grandstream GXV3504 and one Foscam fi8910w. They are all configured for motion capture only.

    I can reproduce the problem with a local browser and remotely from work.

    Just in case the processing overhead is the problem I tried setting all the cameras to passive but I couldn't be sure it made a difference. Maybe or maybe not. In both "all active mode" and "all passive mode" I repeatedly reloaded the same video. Sometimes it would get the whole thing, other times it would only get part of the video.



  • Hi jdhare, thanks for the detailed information, this is very helpful. At this point I'm pretty sure it's a bug in SecuritySpy's HTTPS server, however why it only affects movies and no other files, and why it only affects a small number of users, remains a mystery at this point. We'll do our best to get to the bottom of this!
  • Hi Ben

    I'm using a Mac mini as well. Unfortunately I don't know how to do the nginx reverse proxy and don't want to open http. I look forward to the https bug fix. If needed pls contact me and I can do a join me session in case you want to debug. Thanks!
  • Hi Ben, add me to the list. I cannot retrieve any captured files when using HTTPS. It will download approximately 98% of the file and stop.
  • Hi all, this problem should now be fixed in the latest 3.4.2b7 beta version of SecuritySpy.

    Please confirm.
  • It also seems to fix some issues I was having with the HTTP Server as well. I was using the 3.4.b5 beta and many problems I was having suddenly went away with that version. This seems even better. By chance is there somewhere in this new version a way to hide the PTZ options on the web page for HikVision cameras that don't actually have PTZ ? ( yea I know... are they never happy... LOL ) I was on the verge of moving to a HikVision NVR when the 3.4.b5 beta suddenly made many problems go away. A part of that reason though is at one site I'm running on a older Mac Mini that only has a Core 2 Duo processor and 4 cameras is about all it can handle. So it was becoming a toss up between NVR and a newer Mac Mini. Right now though with the setup I have it seems to be really solid with Security Spy. This buys me time to wait out Apple for an update to the mini. I found your system calculator to be a very useful tool that let me play around and see how much power is needed. I had gotten my system to the point that it wasn't network issues anymore.
  • doodah - great to hear the beta version has resolved all your problems. I'll be releasing this ASAP as a full 3.4.2 update due to the important improvements.

    I've posted a new beta version (same link as above) that has two Hikvision profiles: one with PTZ and one without. So if you select the one without PTZ, then these controls will be suppressed in the software user interface as well as via the web interface. Please confirm.
  • Ben - installed the latest beta and its good. It defaulted right away to the Pan / Tilt version and so I had to modify each camera to just use the HikVision profile and now there are no more PTZ buttons shown on the web page.

    I went back to the web server though and now all of a sudden I only have two cameras showing... I went to the system running SS and when I bring up the window there I see all 4 cameras. But on another system I only see two cameras. I unselected all of them and then selected the two that were not showing and they show fine... but when I have all 4 selected I see the top two cameras but the bottom areas where I should see the other cameras are now just black.... Strange.... It was working fine when I first fired it up and tested.

    So I fired up chrome browser... and voila I see all 4 cameras... shut Chrome down and went back to Safari and now I get 3 of the 4 cameras..... but as an aside.. I'm running the developers latest seed of Mavericks. Went to my Yosemite developer system and the 4 cameras are showing up there just fine right now....

    Anyway... I think the developers OS X might be to blame on that score. I just know from the log files and other issues that I was chasing that the latest beta's look good overall to me.

    Oh crap... I just found that I had more than one browser tab open to SS on the Mavericks system..... closing those down and going with one then its back to tasty pudding goodness.....

    Turn right at the light and keep going until dawn.....
  • Hi doodah - yes you have come across the annoying per-server connection limit that web browsers impose, which is typically 6 connections per server. Any additional connections (in this case to pull in additional video feeds) won't work. See the FAQ How can I view live video from more than 6 cameras simultaneously using a web browser? for more information.
  • Hi Ben... so each camera feed is a separate connection to the web browser page ? Makes sense. I was having some problems viewing last night from iPad, but I'm thinking that possibly it was having some memory issues... I wish it would "multitask" a little differently. I will kill off anything in the background today and retest with it. I also found this morning that I had screen sharing open to the SS mac mini and I'm thinking that could also have dragged down that system. It's on the edge of being able to handle the 4 camera feeds I have it configured for. The beta seems to be very good. How soon before you put up a new release ? I wish you would post an entry in the forum when you do that outlines what has changed, etc.... I don't always catch the tweeter feed on your home page and I'm out to be the last person on earth that doesn't twitter, Facebook, or whatever else they come up with... LOL
  • Yes, each camera feed displayed in a web browser operates over its own connection.

    I've just released version 3.4.2 as a full update - please install it and confirm everything works as expected.

    We have found that twitter is a good way to let customers know about updates, but if you don't want to use it there are other ways to get notifications of changes to web pages - hopefully one of these will be useful for you.
  • I was very excited to install the new 3.4.2 version and I've found that using HTTPS and viewing captured files only seems to be working in Google Chrome for me. Not in Safari. In Safari it won't load past the QuickTime "Q" logo for the embedded player. Any ideas why? I reset Safari to defaults as well and still couldn't get anything to load. Videos loaded immediately in Chrome for me.
  • By default, SecuritySpy will automatically create for you a self-signed certificate in order to provide HTTPS services. Safari unfortunately requires an official certificate signed by a recognised Certificate Authority, rather than a self-signed certificate, in order to display movies from a web server - to get a real one follow the instructions in our blog post How to purchase and install an SSL certificate for SecuritySpy.

    Chrome and FireFox both work fine with the self-signed certificates for viewing movies.

    It's unfortunate that Safari has this limitation, even after manually accepting the certificate when first loading the web interface, but there's nothing we can do in SecuritySpy to get around it.

    Great to hear that everything works well for you on Chrome with the new version!
  • Ben - All looks good on my HikVision system... I will install it today at the other site which is all Dahua cameras, but I haven't been having many problems there as it is running an i7 based mini. It seems most of my problems right now are all based on having a 2009 mac mini that just doesn't hold up well to the load put on it. I've thought about putting a NAS in place and let the HikVision cameras do their own motion detection and then save the recordings to the NAS, but its just not as clean as the interface afforded by SS. Have you ever thought of letting those cameras that can do their own motion detection be integrated and offload that work from SS to them ?
  • doodah - some cameras can indeed record directly to NAS devices but as you say the usability of this is not great. It's much better to have the cameras all in one place being recorded by SecuritySpy. We have no plans at the moment to support cameras' direct-to-NAS recording capabilities in SecuritySpy, as these capabilities vary a significantly between different camera models and manufacturers. It would require a lot of work for us to implement the various APIs for each manufacturer, and it would be a significant change in direction for our software.

    Best performance can be obtained by setting SecuritySpy to capture the video and audio from the camera directly to disk with no further compression - this fully utilises the camera's encoding capabilities rather than the computer being burdened by this task. This setup is described in the Optimising Performance section of the SecuritySpy user manual.
  • Hello, I'm experiencing the same issue. I am not able to view the videos in web interface or remote patrol on 3.4.2 when using HTTPS. HTTP works fine. I will installed an official certificate per your instructions.thanks
  • Both iOS and Safari on OS X require an official SSL certificate in order to display movie files over HTTPS. So obtaining and installing one should resolve your problem @BIGBUFF74.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!