PTZ Presets with DLink 5222L
  • Hi,

    I think something is not working right for my camera (Dlink 5222L) and SecuritySpy PTZ Presets.

    I have done some troubleshooting and this is what I found.

    I can save my camera positions when clicking alt-preset nr, and when I log into the camera, I can see them listed "1" , "2", etc...
    From inside the camera setup, I can move the camera to those presets, and they are the correct positions (that I have saved from SecuritySpy), but when I recall these presets from SecuritySpy, the presets do not move to the correct positions at all.
    In fact, all preset numbers move to the same position, and the center dot (which moves to another position) is not really the home position at all.

    So it seems SecuritySpy is able to save back to the camera, but cannot correctly read the positions from the camera.
    I have entered my username and password inside the camera setup, even entered the http and rstp port numbers, ssl is not enabled.

    Am I doing something wrong ?
    (I am almost certain that this has worked before)

    Any help is appreciated. I would love to get this working.
    Also a small feature request if I might, if I get this working, it would be very cool if I could also schedule the PTZ presets.
    This camera is located behind a window, but at night the IR just reflects and this camera is of no use looking outside, so it would be cool if I could automatically have the camera turn to inside the room at night.

    Best regards,

  • As a followup, I have done some further testing.

    I already had a few presets created in the camera itself. I have gone ahead and deleted all the presets inside the camera and started a fresh from within SecuritySpy.

    I now have my home position and preset 1 that are correct, but when I move the camera to a different spot and save it in SecuritySpy as preset 2, the camera records the correct position, but SecuritySpy does not read the correct position from the camera.
    Instead SecuritySpy insists that my preset 1 and preset 2 positions are identical, but inside the camera I can manouvre to these two presets and they are the correct positions.

    I have also tried disable and re-enabling the camera (to see if it reads the positions form the camera), and I have also tried quitting SecuritySpy and re-launching, but still no luck.

    There is nothing relevant for this camera in the log file.
  • Upgrading my camera's firmware to the latest version (1.11) solved this problem.

    About the PTZ preset schedule, would this be possible with applescript ?
    Ifso, could you please give me any tips to get me going ?
  • Hi Pete - great to hear the firmware update resolved the problem.

    A PTZ patrol is indeed possible with a simple AppleScript - we have one on our AppleScript Examples page.
  • The applescripts work perfect.
    I have created two scrips and call them every day with cronnix. Thanks !

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!