-1004: Could not connect to the Server (Network Failure Getting Status)
  • Getting this error on Remote Patrol, but I can't see anything through the Security Spy dashboard app either. Feel like it might be a tunneling issue, but everything seems to be correct through router - DNS set up, etc. Also web server settings in Security Spy seem ok too. When I'm at home I can see all cameras on computer Security Spy is set up on. Not sure what the issue might be.
  • When you are at home, can you use a web browser (e.g. Safari on your iPhone) to connect to the SecuritySpy web server? For example if your computer's IP address is 192.168.1.10 you would connect using the URL http://192.168.1.10:8000

    Then when you are connecting from other the internet (e.g. switch off WiFi on your phone so it is using cell data), and you use your DDNS address (e.g. http://yourname.viewcam.me:8000) does this work?

    If the former works but not the latter then there is some problem with your port forwarding setup. Have you followed our instructions for setting up remote monitoring?
  • I'll try the web browser at home and the phone away from home using cell data. I think it may have something to do with port forwarding.

    I have port forwarding set up through DYNDNS. In the web server settings I just have the dyndns location and nothing entered in viewcam.me. Do I need to set up both or just one?

    Oddly enough, this morning my Remote Patrol and Dashboard app from work seem to be working. Can also access Security Spy web server from work. Can't explain why it seems to be working now.

    I'll monitor and respond to this comment if anything changes.

    Thanks much!
  • So I feel like it is something to do with the Port Forwarding. Everything looks correct on the router re: port forwarding, but I have a few questions...

    - Does the 8000 port name need to be the same as the Server Name in Web Server settings in Security Spy? Currently I had it as "Security Spy" when my network name is different. What application determines this name

    - In my Web Server Settings it says I have two Local IP addresses - one with 169 another with 192. In my old SS setting I had a screen shot where it said "Your Primary IP address:" and started with 169. Point is they are different and not sure how and what this should be.

    - I noticed in my old Video Device settings that I didn't have port numbers for my wireless cameras. I do in the current set up and doesn't seem to work in Security spy without. Is this correct?

    Trying to narrow this down. Hoping answers to these questions will help.

    Thanks -
    Calvin


  • Hi Calvin, to answer your questions:

    - If you are talking about a name that your router asks for the usage of the port, or a name for the port forwarding rule itself, this can be anything. All the router needs to know is the IP address of the computer and the port (8000) that it must forward to that IP address.

    - If you have two local IP addresses listed, then your computer must be connected to two different networks. Do you know how this could be (e.g. connected by wired ethernet as well as wireless)? If you connect to your router by wired ethernet then you should probably switch off your computer's WiFi to avoid this kind of thing.

    - In the Video Device Settings window in SecuritySpy, you only need to specify ports for your video devices for those devices that use non-standard ports. Standard ports are 80 for HTTP and 554 for RTSP.

    If you are still having problems with access from the internet, if you email us screenshots of all relevant settings (router configuration screens, Web Server Settings window in SecuritySpy, DDNS settings etc.), we will look everything over for you. To capture a screenshot, press command-shift-4 and select the area you want to capture. A file called "Screen shot" will appear on your desktop.

    Hope this helps!
  • Thanks - I changed the network name in Remote Patrol to the actual IP vs the network name and seemed to work. Although once I left home it did not work again. I'm thinking in regards to the two local IPs that possibly my router extender could be possibly causing an issue. Like it may be creating a separate IP as opposed to extended the current network. I'm going to reset and see if that works.

    Copy that on all the rest of the answers and Thanks!
  • When away from home, Remote Patrol was probably trying to connect on the computer's local (LAN) IP address, which only works when you are on the same local network. When away from home you will instead need to use the DDNS address, which is an internet (WAN) address. If you have used SecuritySpy's DDNS system, this will be in the form http://yourname.viewcam.me:8000/

    If you edit the server configuration in Remote Patrol, there is an option there to enter both the LAN address and the DDNS address, and it should intelligently use the correct one depending on which network your iOS device is connected to.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!