Trivision NC-223WF HD 720P
  • Has anyone gotten this to work with RTSP? I am using the Sharx Network camera setting, which appears to work fine for MJPEG, but the RTSP setting gives an Authentication error. I am also using a Trivision NC-306P (similar to the Y-Cam) which works fine with the RTSP setting.
  • Hi Dean, these could both be rebranded Sharx models, I'm not sure exactly because I've never heard of TriVision cameras before. The first thing to do is to log on to the camera using a web browser, look for an "RTSP Authentication" option, and turn it off. This usually resolves these kinds of issues. SecuritySpy does support authentication over RTSP, however different cameras implement this in subtly different ways, and it is sometimes necessary to turn off this feature in the camera to get it to work. Let me know if this doesn't fix it.
  • I disabled Authentication for the Primary & Secondary Streams. I am still getting an authentication error as follows:

    11-06-2013 1019-19: Error communicating with the network device "Sharx Window" 3.1.2,80201,401 Authentication error

    The ports are as follows:
    HTTP/RTSP port: 80
    RTP port range: 30000 --30200

    BTW, just for your notes the Trivision NC-306P (P for POE) works fine with the Sharx Network Camera setting with RTSP authentication enabled. Probably all the Sharx type Trivision 'clones' (for lack of a better word) will probably also work. The NC-223WF doesn't look like any Sharx models so therein might lie the difference.
  • Hi Dean,

    This error indicates that the camera requires Digest (encrypted) authentication, not just plain-text authentication which is typically used. SecuritySpy support this, but the camera seems to be rejecting the details that SecuritySpy is supplying.

    I know this is obvious, but please double-check the username and password you've entered into SecuritySpy. Make sure they are the correct admin login for the camera.

    Also, I've made some changes to the way that SecuritySpy handles this Digest authentication and I've sent you a link by email to a beta version of SecuritySpy for you to test.
  • Ben,

    I was trying your beta version when your suggestion about the password led me to the problem. When I set up cameras I always create user accounts for viewing the streams and the admin account is purely used for admin. After mucking about I discovered an apparent error in the firmware. I am able to access the RTSP stream, but only from the admin account and not from the user accounts. The MJPEG streams works in either. The clue, I suppose, is that even with authentication disabled, it was still causing an authentication error in SecuritySpy. So, the following seems to work for SS beta and the current V3.1.2:

    Trivision NC-223WF Firmware: 5.53 (build 20131008)
    Authentication Enabled, 'Digest' or 'Basic' both appear to work
    MJPEG stream - user or admin account
    RTSP stream - admin account only

    Obviously this is a bug in the firmware for this camera, since my other Trivision works correctly allowing either RTSP or MJPEG to be streamed from the user accounts. I will notify Trivision but the firmware will probably take a while to be updated (if ever.) If I discover anything else, I will post it here. Thank you very much for your time and fast responses! If you wish me to test anything with the beta software please let me know.
  • Hi Dean,

    Glad you worked it out, and thanks for posting the solution here.

    I agree with you: user access should allow access to the stream in either HTTP or RTSP mode. Unfortunately there is no consistent way that manufacturers implement this kind of thing: I've seen plenty of other cameras that require admin access for some/all streams, so it's certainly not unique to Trivision cameras. We tend to advise users to always use admin access in SecuritySpy (it's normally required for PTZ control anyway, for cameras that have this feature).
  • I just purchased and set up the Trivision 336PW HD 1080P camera. Access through the default web browser and recommended iOS app AnyScene worked well. Tried using the Sharx profile as mentioned here with success except no audio. Tried the Y-Cam and that is showing audio capability but not actually receiving any audio from the camera. This is the MPEG-4 RTSP-over-HTTP format. Anyone have any thoughts/suggestions?
  • Hi @trg - when using the Y-Cam profile with this camera, with the MPEG-4 RTSP-over-HTTP format option, you should see a small speaker icon next to its listing in the "Camera Status" window (available via the window menu). Do you see this speaker icon there? Clicking it will play the live audio through your Mac's speakers.

    Does this work?
  • from WHD email from trg: I see the icon, but no audio is being transmitted in live view or recordings. The axis cameras audio are working as expected.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!