h.264 on arecont vision av2125IR not working
  • I'm doing the trial and I can get the camera to work as "JPEG HTTP (video only)". However if I try "H.264 RTSP (video and audio)" I get the blue screen with the x in it and the reconnect countdown.

    I also tried manual configuration using a request string generated by the cameras H.264 web UI.

    This camera is listed as supported and with H.264 on the camera list (http://www.bensoftware.com/securityspy/helpcameralist.html)

    Is H.264 not supported in the trial? Or am I doing something wrong?
  • Generally this problem is caused by Perian being installed on your computer. This interferes with SecuritySpy's ability to decode the H.264 stream and must be uninstalled. If you are still having this problem after uninstalling Perian, please email us your log file, which you will find in the SecuritySpy folder within your Documents folder, and we will take a closer look.
  • You're right. I installed an instance in a Lion VM that didn't have Perian and H.264 works just fine. Thanks!
  • Yep I just stumbled on this post and uninstalled perian and now the h.264 codec works with my avtech cameras 257 and 357a and it can use the full framerate of the camera, but the video quality is significantly lower than mpeg 4.
  • There should be some quality settings in the camera to adjust the amount of compression applied to the H.264 video stream. You'll either have a fixed bit rate (in which case increasing the bit rate or reducing the frame rate will increase the quality), or you'll have a variable bitrate with an adjustable quality setting, in which case increasing this will improve the visual quality.

    If there is a choice between the two schemes, I'd recommend using a variable bit rate and a "high" (or equivalent) compression quality setting. This way, you will get a consistent visual quality and the camera can adjust its bit rate in response to what is actually in the video image, resulting in an efficient stream.
  • Thanks for the response, I've been tinkering but in the video devices setup in SS the video size, quality and framerate are greyed out. In the browser configurations there are options for setting maximum framerate, and maximum bitrate. Even though I set the maximum framerate to 15fps in the h.264 configurations and increase the max bitrate to 5000, when I return to SS it is still running at 30 fps and a really poor picture.
  • Hi Peter, sometimes cameras allow the client (i.e. SecuritySpy) to request certain parameters such as frame rate, quality etc., however other cameras (such as yours) do not - in this case these options will be greyed out in SecuritySpy can you will have to connect to the camera with a web browser to adjust its settings.

    After you change the stream settings in the camera, restart the camera and quit and reopen SecuritySpy - hopefully this will make the new stream settings come into effect.
  • thanks Ben, tried that, in the browser, I set the h.264 options to HIGH, max framerate to 15, max bit rate to 5000 and no joy, SS is still running the camera at 30 fps with a really poor picture in h.264 format. Oh well, mpeg 4 is adequate for my needs, I just like to resolve niggles like this. Curiously Videoviewer ( supplied by Avtech ) , reports that the camera settings have been updated and are 15 fps, HIGH quality ?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!