IOS (14) Clients can't find LAN servers.
  • I've got a couple of SecuritySpy servers running on macOS 10.15.7 and 10.15.6, and everything works fine _EXCEPT_ LAN connections from IOS (14) devices. If I disconnect from WiFi and use cellular data, I can get to both servers, but if I turn the WiFi on, I can get to the one that's not on the LAN, but get "Connection Failed, Unable to connect to the server." for the server on the same LAN.

    I'm upgrading one of my servers, so I set up the new one (macOS 10.15.7, no other programs installed) with a trial license, and get the same result. Strangely, if I use the IP address of the new server (192.168.1.138) I get "Connection Failed. You're not connected to the Internet. Check your connection and try again." (except I clearly am) but if I use the DNS name (polaris.local) I'm back to "Connection Failed, Unable to connect to the server."

    Everything works fine from desktop SecuritySpy clients and from web browsers (macOS or IOS14 Safari) pointing at http://polaris.local:8000 or https://polaris.local:8001 with and without a web account, it works fine.

    Unfortunately(?) we've upgraded all the IOS devices here to IOS 14, so I can't say for sure if it was an IOS 14 problem.

    I've enabled logging, but nothing is written to ~/SecuritySpy/Log.txt (but then nothing's logged there for client connections anyway, AFAICT).

    I tried Beta 5.2.6b6 to no avail.

    Am I doing something wrong?

    Thanks!
  • iOS 14 has a new security restriction whereby users have to grant permission to apps to access other devices on the local network. Our app should ask for permission the first time you run it, but perhaps it didn't for some reason, or perhaps permission wasn't granted (the message is only displayed once). Or perhaps you need to update your iOS device to the latest version of our app, which was released last week.

    So the thing to do is to first make sure you're using the latest version of our iOS app (via the App Store on your device), then go to the Settings app, scroll down and tap on SecuritySpy, and make sure the "Local Network" permission option is turned on. Does that do it?
  • That was it, thanks so much! Not sure why any of our devices wasn’t set to allow network access, but it’s working now. ????‍♂️

    Thanks again!
  • FYI same issue: couldn't connect with latest version of app if Wi-Fi was on — iOS 13. Came back to it today after upgrading to iOS 14.0.1: got the security dialogue first time, then a connection error, then had to re-enter SS username & password. Now I can see the cameras again :]

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!