SecuritySpy v. 5.2.4 no longer uploads to server if camera window is closed.
  • Previous version of SS uploaded Webcam image "upload and replace image on server" perfectly without the "cameras window" open. Now with v. 5.2.4 uploads stop or are intermittent when the "cameras window" is closed. If I open the "cameras window" then uploads resume. If I leave "cameras window" open my 2011 27" iMac running High Sierra v. 10.13.6 starts to heat up significantly. How can I fix this?
  • This sounds like a bug, we'll look into this.

    For now, please make sure the option under General -> Preferences to "Decompress incoming video frames only when required" is turned off. Does this resolve the issue?
  • Yes, "Decompress incoming video frames only when required is turned off. I don't know what happened but now it operates as required - except the computer is heating up even when the "camera Window" is not open and the program is running in the background. I have to put the monitor to sleep to stop it. SS still sends the files to my servers when the screen is asleep. I checked Activity Monitor and noticed "VTDecoderXPCService is running at 365.7% CPU. SecuritySpy at 21.5%.

    I use SS to upload images to my WeatherStation site (https://macoun-sask-weather.site/template/indexDesktop.php) at 3.5 minute intervals for 4 cameras, and every 10 seconds to another computer on my LAN side every 10 seconds. No movie recording or motion detection is being used.The cameras are 4 Amcrest 4MP IP IP4M-1026. Also 1 old D-Link camera that I set up inside. One of the AMCREST cameras has a dual profile, one to send pictures to my site and one to send pictures to another computer on my LAN.

    I created a debug file That I can supply.
  • My guess is that your Amcrest cameras are set to a high fame rate, and because your 2011 iMac does not have any hardware video decoding capabilities, the CPU is having to do all the work to decode the incoming stream. Since you don't need movie recording, I suggest you log on to each camera in turn, and set its frame rate to something very low (e.g. 1fps). Keep them at the highest resolution, for best quality. You should find that, with the cameras set to a low frame rate, everything will work much better.
  • Thank you Ben! You nailed it. I reduced the frame rate down to once per second (since they are only weather cameras..) and the "VTDecoderXPCService" dropped from over 365 down to 42. the computer is running much cooler now. Guess it's time to look at a new one.
  • Great to hear this has significantly reduced the CPU usage. If you are using SecuritySpy just for the weather camera upload rather than for recording/security, then a low frame rate is fine and your Mac will perform perfectly well for this task.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!