I'm getting "Failed to decompress" bad data error
  • Example of error message

    10/16/2019 11:56:23: Error communicating with the network device "Garage-HD". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Staff". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Garage". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Front". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Breakfast". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Ballroom-Patio-HD". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Ballroom-Patio". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Driveway-HD". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:23: Error communicating with the network device "Driveway". 5.1.0,70900,800 Failed to obtain video frame from network device. The operation timed out.

    10/16/2019 11:56:44: Error from camera "Staff", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 11:56:44: Error from camera "Ballroom-Patio", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 11:56:45: Error from camera "Ballroom-Patio-HD", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 11:58:03: Error from camera "Garage", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 11:58:03: Error from camera "Driveway", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 12:25:38: Error from camera "Ballroom-Patio", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 12:25:39: Error from camera "Front", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 15:27:53: Error from camera "Breakfast", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/16/2019 15:27:53: Error from camera "Driveway-HD", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.

    10/17/2019 14:02:25: Error from camera "Driveway", it will be closed. 5.1.0,22185,-12909 Failed to decompress incoming video frame. Image data decompression failed - bad data.
  • This error indicates that some data from your cameras cannot be decoded. Possible causes of this are as follows:

    Network: make sure that the cameras have a fast, reliable network connection to the Mac. Use a Gigabit Ethernet switch from a reputable manufacturer, with all devices connected to this switch (don't use your router as a switch). Avoid WiFi.

    Cameras: make sure you are using the latest firmware available from the manufacturer.

    Video encoding: check the encoding settings on the cameras. Use H.264 Baseline or Main encoding, with VBR encoding. If your cameras support H.265 you can try this too.

    Frame rate: try lowering the frame rate at which your cameras are sending video (e.g. try 10fps). This will reduce the load on the network and the Mac.

    If, after trying the above, you continue to have problems, please email us and we'll help you directly with this.
  • Did you get this fixed?

    I am having this issue with a Foscom R2c even after trying Ben's recommendations above.
  • livefeed - does the R2c support h.265, and if so, is that currently enabled? Try switching to h.264 if so and see if the issue goes away. I have 3 different models of cameras supporting h.265 but if I have that enabled for the stream I will get the bad data errors in SS. I do not get these with h.264.
    jvss000 - same questions, though on yours I would add that it looks like there could be a network issue involved. From your SS computer can you run a constant ping against the ip of one of the cameras having an issue, and see if it has any drops?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!