Google's new app password, email no longer working
  • I tried setting up SS with Google's security that generates a specialized PW for an app.

    My settings are:

    SMTP server
    smtp.gmail.com (with and without :465)
    myemail@gmail.com
    ALERT
    myemail@gmail.com
    (special PW created by google)
    Explicit

    I'm wondering if google is looking for the subject line to match in order to use the PW? How does Google know the email is triggered by SS? Unless...it's coming from my, to me so therefore doesn't need the special PW.

    I'm using the PW because I was getting emails that I had an unsecured app that had access to gmail.

    thoughts appreciated
  • I've just tested this and it's working for me. The settings you describe seem correct, but there must be some configuration problem somewhere.

    When you generate an app password, google gives you a 16-digit password. Make sure you are entering this correctly, with no spaces. The "From" name can be anything you like, so "ALERT" should be fine. You don't need to enter a port number with the SMTP server address (just smtp.gmail.com).

    When you click the "Test" button under Preferences -> Email in SecuritySpy, what is the error or message displayed?
  • I will double check my entry today. I might have a related problem though.

    Could this cause SS to close unexpectedly?

    Happening at least once a day. Nothing unusual in the SS log. The crash report:

    Process: SecuritySpy [13965]
    Path: /Applications/SecuritySpy.app/Contents/MacOS/SecuritySpy
    Identifier: com.bensoftware.SecuritySpy
    Version: 4.2.10 (4.0)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: SecuritySpy [13965]
    User ID: 501

    ...
  • This shouldn't be related, but I would like to have a look to see what could be causing this. I'll need the full log - please attach it to an email to support@bensoftware.com and include a link to this forum discussion.

    These logs are located in the ~/Library/Logs/DiagnosticReports/ folder (within your user folder).

    To get to the Library folder, hold the alt key while clicking the Finder's Go menu, and select the Library item that will appear in this menu.

    Thanks
  • Ben, thanks as always.
    I deleted the old PW, generated a new one and typed in (vs cut/paste) and everything worked fine. It must have been the spaces.

    I've also sent you the log regarding the other matter.
  • Great to hear that, thanks for reporting back.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!