'Load More Results' fails when viewing Captured Files via Web interface
  • When viewing Captured Files from March 1st, 2019, I can only seem to load the first page of results. Scrolling to the bottom and clicking the 'Load More Results' button results in a 'Loading...' message that never goes away.

    I logged into the server and used the browser interface to view the same camera on the same day and all the videos are there and play back without issue. There is nothing particularly different about that day's footage so I'm curious as to why this happened. I can only guess that the loader script (AJAX?) is failing for some reason... maybe there are too many videos?... perhaps a corrupted thumbnail image for one or more of the videos?

    List or grid doesn't seem to matter. Same thing happens when viewing other cameras as well but viewing other days (that I've tried) seem to be ok.

    I upgraded to the latest version of SS but it still won't load March 1st past the first page.

    Any thoughts?
  • It sounds like you may have Javascript disabled in your browser - is this the case? What browser are you using?
  • I actually tried it in both Safari and Chrome on my Mac... and Javascript is enabled in both. My client was the one that brought this to my attention as it is her camera system. I'm pretty sure she uses Safari on her Mac and I have no reason to suspect that she has disabled javascript.
  • Is there a log file on the server that I could check?
  • OK, that continuation token (which is meant to keep track of where you are in the overall file list) is wrong. Also, the request, even with an invalid continuation token, should not be returning an empty response. So this looks like a bug in SecuritySpy rather than a configuration problem at your end. I will look into this and get back to you.
  • I'm looking at this now and I have identified some areas of improvement we can make to avoid the issue you are seeing. however it appears there might be a problem on your particular system in regards to obtaining file creation dates, which points to a potential issue with the format of your drive. What drive are the captured files stored on, and what is the format of the drive? Ideally you should be using a Mac-compatible format such as Mac OS Extended or Apple File System (APFS).
  • It's saving to the boot drive (the only drive) on the Mac mini. It’s formatted as Extended (Journaled).
  • OK thanks for the info. I've prepared a new beta version of SecuritySpy for you to test - you can obtain it from the SecuritySpy beta version page. Please quit your current SecuritySpy, download and run this one, and test this function and let me know if it now works as expected.
  • Yep... that did it! It now allows the user to load the next page of results. Thx!
  • Excellent! Thanks for the swift testing. This fix will be in the next official update, but for now it's fine for you to continue using this beta version.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!