Failed to open network device. Network is unreachable.
  • I am running version 4.2.9 on a mac mini running 10.10.5.
    It seems to work great, but at times I will get inundated with the message bellow:
    Error communicating with the network device "HTENC-COMMONS-EAST". 4.2.9,70902,800 Failed to obtain video frame from network device. The operation timed out.

    Sometimes from one camera, most times its all the cameras, when I investigate there are videos recorded for the time of the error and the videos look good.

    Is there any way to suppress the errors? The videos look good, getting alerted that 1 frame is dropping seems a bit of over kill. Is there some way to make the threshold higher?
  • When a camera stops responding (which is what this error indicates), SecuritySpy will attempt to connect to it immediately. If this succeeds, no error is generated. However, if this reconnection fails, then you will get an error being generated. SecuritySpy will then attempt to reconnect periodically until the camera comes back online.

    So, while this error apparently does not indicate a serious problem (because according to what you say it must be coming back online quite quickly and continuing to record), it does indicate an error that has caused a short period of downtime that is certainly more than 1 frame.

    It may be sensible for us to suppress this message if the camera comes back relatively quickly (e.g. within 1 minute). This should reduce the frequency of these messages, while still making sure you are informed of a serious problem. I'll see if we can do this for the next update.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!