Lot of slowness/connection issues
  • Hello,
    I recently "upgraded" to high sierra. Although I am not 100% sure if this is the cause of my issues.
    Ever since the upgrade, the SS server has been quite slow. When I use the ios app, or I try to view cameras thru IndigoDomotics software, each camera takes a few seconds to begin streaming. It used to be almost instant.
    In IndigoDomotics, I am using the following URL to get the stream:
    http://username:password@192.168.0.26:8000/++image?cameraNum=0

    Even in the iOS SS app, the stream takes an extra few seconds to connect, the stream isn't smooth. It is doing about 1 frame for every 4 to 5 seconds.

    Something just isn't right.

    Another clue, prior to switching to high sierra, I completely erased the hard drive, and installed a fresh copy of high sierra. So I had to reconfigure SS. Before this, the CPU load would be around 80%. I have 24 cameras connected to SS, so it used a lot of power.
    Now it only uses around 20% CPU. I am guessing some setting is different.

    Anyway, something isn't right. SS is the only thing running on this computer.

    Any ideas?
  • I wonder if High Sierra is entering a "nap" like mode during display sleep. Also, I would want to verify that SS is indeed set to not sleep. My diagnostics in this situation would be...

    1. Check the Energy tab of Activity Monitor. Verify SS does NOT nap.

    2. Set display shutdown to never in Energy Saver panel.
  • Ok, I did some further testing, and it isn't high Sierra.
    I tried putting SS on my 2016 Touch Bar MacBook Pro 2.9ghz i7 with 16gb RAM. It worked great. Very fast. It is also running high Sierra.
    I formatted the HD on the SS Mac, and reinstalled the OS, and still no luck.
    It is a 2012 MacBook Pro with quadcore i7 2.7ghz and 16gb RAM. Granted it is older architecture than my 2016, but is there that much of a difference?
    Could it be that my SS MacBook just got burned out from running at nearly full CPU for about 2 years?
    My next guess is maybe just the network adapter got burned out and is slowing things down. Just for testing, I will try and run the SS MacBook thru the wifi connection instead of ethernet.


    In the mean time, I am looking on eBay for a used Mac Pro.
    Would a 2009 12-core (dual 6 core xeon) approx 2.4ghz or 3.3ghz with 32gb ram be able to handle my 24 fiscal 1080p cameras? Or is 2009 too old?
  • BTW, all 24 cameras are doing continuous recording 24/7 and motion detection recording.
  • One other question here too.
    For SS purposes. Which is most important? CPU clock speed, number of cores, or newest architecture?
  • There is no particular reason why you should be getting slow performance in this situation. Here are a few things to check:

    - Try updating to the new 4.2.4 version of SecuritySpy (use the "Check For Update" option in the SecuritySpy menu in the software itself).

    - In SecuritySpy's general preferences, make sure the "Decompress incoming video frames only when required" option is turned off. This option can save CPU usage, but leads to slower web server performance (check the manual via the link above for a more extensive discussion of this option).

    - Check performance in a standard web browser (Safari or Chrome). Is this also slow?

    As for your hardware question, our system requirements calculator will give you a good idea of what hardware is required for a particular system setup. A 12-core 2009 Mac Pro is still a very fast and capable machine, and should easily be able to handle 24 1080p cameras with very good performance.

    CPU clock speed is important, but clock speeds haven't increased much in the last few years. Likewise, newer architecture will perform better than older architecture, all other things being equal. But number of CPU cores is the biggest factor in SecuritySpy's overall performance.
  • Hi Ben,
    Thanks for the detailed reply.
    My SS macbook pro was using 4.2.3 but so was my 2016 Touch Bar MacBook Pro. So that isn't the issue. I just updated to 4.2.4 right now.

    The decompress option was already turned off. CPU usage is actually quite low, which leads me to believe that there is an issue, because a few months back, the usage used to be VERY high, but I also didn't have any issues. It worked fast.

    I also tried running it thru wifi instead of ethernet, and same issue.

    There is one other possibility here. This is a 2012 MacBook Pro. The battery was bulging to the point that it was pushing the trackpad out of place. Apple told me that they no longer make this battery. They said it could be safely removed and just run on AC power, which is all I need anyway.
    I removed the battery. I just ran a google search, and it seems like the Mac slows down significantly when the battery is removed.
    Only available batteries are aftermarket ones on eBay/amazon. Anyone know about this? Maybe there is a setting to let the computer run full speed again without the battery?
  • Yes, no battery = slowed CPU clock.

    I've had good luck with 5 Runpower brand (via Amazon) aftermarket batteries on several old MacBook unibodies that are still in daily production use. Runpower replacement batteries have worked without problems.
  • Ok, apparently it is called "SpeedStep". It is a function built into intel CPUs that apple is using to slow down the cpu when battery is no good, or removed.

    No I have to figure out how to work around that.
  • Thanks guykuo, maybe I will try that.
  • I can't think of anything specific to SecuritySpy that might cause a slowdown on this particular machine.

    The battery issue is intriguing, and not something I've come across before. What you are describing is consistent with the CPU being throttled/limited at the OS level. From what I am reading on other forums, it seems that these MacBooks do throttle their CPU when the battery level is low, to preserve battery power. With the battery removed, macOS thinks its level is permanently at 0%, so the CPU is always throttled.

    Try this Terminal command:

    sudo pmset -a dps 0

    This is supposed to disable CPU throttling on some Macs. Does this make a difference?
  • "sudo pmset -a dps 0" didnt work.
    I will try the other method later on and update this thread. Thanks.
  • Couldn't get the other working either. I think it is for a different architecture than mine.
    Anyhow, not a problem. I ordered a new battery. I also bought a used 2009 mac pro 12 core 3.3ghz system. I will sell this one with the new battery for about $200 less than what I paid for the mac pro.
    For me, and my setups, it ends up being a better solution anyway.

    Thanks for the excellent support Ben.
  • OK, thanks for reporting back, it's a pity that neither of those solutions worked for your MacBook.

    I think you have made the right decision to switch to the Mac Pro - it's much more suitable anyway, and I think you will get great performance when it's all set up.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!