IOS app - re-connect to failed cameras
  • Hi Ben,

    If one of my cameras goes offline and then comes back online, the IOS app retains a red X across the camera window without picking up that the camera is live again. If I force close the app and re-open, it fires back up fine.

    Would it be possible to add in a check in the app check in with the server that its live again?


    Cheers!
  • Hi Andy,

    I'm afraid I can't reproduce the problem - the app does exactly this and I can't find a fault with it.

    Are you sure you are using the latest version of the app and SecuritySpy itself?
  • Weird, maybe something with my iPhone, Yup 4.1.6 and the latest from the app store.

    Strange, I wonder if its something to do with the camera in question, maybe the Samsung app polls it in a different way to wake it up. Its the camera connected via wifi where as the other is via ethernet. I'll check it out, cheers
  • I've seen this... sometimes - although I'm not sure if it has happened since Mac app 4.1.6 and the latest iOS app. I'll watch it more closely.

    Recently If I leave it for a few seconds, it does come back after getting the X through it. I had seen cases in the past where it wouldn't, but appears to be resolved.
    In the past I'd seen like AndyUK - where the only way to fix it was to quit the iOS app, and start it up again.
  • Has anyone tried the iOS app with iOS 11 beta? I know all the warning about beta, but I'm seeing this happen a lot with the beta, and also seeing it not connect to the SS server at all.

    Not expecting beta support, just want to give a heads-up as Ben might want to take a look just to see if any unexpected upgrades or fixes will be needed to support iOS 11 in a few months as I know they keep changing the networking stack to have stricter security, etc.
  • Hi @Spiv - there are currently problems with the iOS 11 Beta that affect our SecuritySpy iOS app, so I wouldn't recommend installing the beta presently.

    @BrainM - we'll make sure to test this thoroughly and make reconnect more robust in the next update.
  • I've been watching as I've used it over the past couple weeks, it always seems to sort itself out for me with the most recent versions within 5-10 seconds it will restart the stream if it does show the X, I haven't had to quit the app in iOS to get it working again with the most recent versions of iOS & Mac app.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!