PTZ bug
  • Having Trouble with the PTZ when the presets are clicked nothing happens and the PTZ controls do not do anything. PTZ unfreezes a few mins later but presets are unusable.

    This is a new issue after the updating to the new version.

    I am using a Hickvision PTZ cam.
  • Could you tell me which "Profile" setting you are using for the camera, under Preferences -> Cameras -> Device?

    Please could you try both the "Hikvision" profile and the "ONVIF" profile, and let me know if you see the problem with just one of these, or both.

    Also, please confirm exactly what version of SecuritySpy are you using.
  • Same issue here. I can manually move cameras using PTZ controls but all of my presets have stopped working. I'm using the Hikvision Profile with 4.1.4 of SecuritySpy.
  • I am using 4.1.4 and have been using the Hikvision profile, have tried the ONVIF profile and does not seem to improve the situation.
  • Could you please let me know exactly what behaviour you see with the ONVIF profile. Is it exactly the same (i.e. PTZ works but presets don't), or is it different in any way?

    Also, do you know what version of SecuritySpy you were using before, when the presets worked with the Hikvision profile?
  • Yes it is the exact same behaviour, the PTZ works, presets don't work then PTZ is frozen after attempting to use the presets (unfreezes after a couple of mins).

    Not sure which version I was using of SS I was using but had downloaded it within the last 6 months.
  • Sorry Ben is there any feedback on this issue?
  • Hi Ben sorry to be pushy but this is still an issue and quite a big problem for us. Any feedback on this issue?
  • Hi @starks sorry we haven't been able to fix this for you yet.

    So that we can narrow this down to a particular SecuritySpy version, please try the last few point releases and let us know which ones suffer from this problem. If we can pinpoint the exact SecuritySpy release when this started, I can go back and look at what changed in the PTZ code between the two versions, which should enable me to find the issue. The last few releases are here:

    4.1: http://bensoftware.com/securityspy/SecuritySpy41.dmg

    4.1.1: http://bensoftware.com/securityspy/SecuritySpy411.dmg

    4.1.2: http://bensoftware.com/securityspy/SecuritySpy412.dmg

    4.1.3: http://bensoftware.com/securityspy/SecuritySpy413.dmg
  • Also, we've just released a new beta version of SecuritySpy (current 4.1.5b17) that has some improvements related to issuing PTZ commands - please could you try this and let me know if you see any difference (at least the freezing of the PTZ controls should no longer happen).
  • Thank you will give this a try tomorrow and get back to you about the results.
  • Hi Ben none of these worked 4.1-4.1.3 all had the bug with the presets and froze the ptz controls for a while.

    The Beta version does not freeze the PTZ controls, but the presets do not work.
  • Ok the presets work with all of those 4.0.6-4.0.9 so looks like it was 4.1 onwards that caused the problems.
  • Many thanks, this has allowed me to track down the problem, it should now be fixed in the latest beta version of SecuritySpy (currently 4.1.5b20). Please confirm.
  • Hi Ben, works with the Hikvision profile now, but not with the ONVIF. Thank you!!
  • Hi @Ben,

    Just an FYI if you're interested regarding PTZ commands... I've noticed recently that I need to re-send PTZ position change requests from the iOS app in order for the request to take. The funny thing is that I don't know if the problem started right after an update since I haven't updated the iOS or MacOS app since the 4.1.4 / 1.1.1 updates many weeks ago. But In the last week or two I have noticed that rarely will the PTZ position change on one tap. I need to re-send the request two, three, or sometimes more times in order for the position to change. Maybe this is already fixed in the latest beta - I haven't tried it yet.

    (I'm running Amcrest cams on the Amcrest profile in MacOS app)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!