constant disconnections with 4.1.3
  • Ben, I didn't experience any connections issues with 4.1.2, ever. I'm getting disconnections constantly with the new version. Is there a way to downgrade back to 4.1.2? My cameras (6 - all Amcrest 841) are unusable on the new version.

    Anyone else seeing this?
  • found an old version in "downloads" 4.1, installed and running perfectly again. Any ideas? Or can I get a link to a beta or 4.1.2 again?

    I'm sending "diagnostic information back to developer" if that would help.
  • I can't think of anything that changed between 4.1.2 and 4.1.3 that could cause this problem, and I've tested with our Amcrest camera here and it seems to work great, so I'm not immediately sure what could be going wrong here.

    You can download the previous version here: Download SecuritySpy 4.1.2. So please download this and run a few tests with 4.1.2 and 4.1.3 and let me know the results.
  • thanks ben - I'll report back
  • Ben, I've tested (reinstalled, rebooted SS server, rebooted network) all variables and still get constant disconnections (usually starting around the 5 minute mark). All the streams start fine, and then begin to disconnect, reconnect continuously. When I go back to 4.1.2, everything is perfect again. If you need any logs, let me know, I'll do whatever is needed.
  • I've been having similar problem with 2 of my 6 cameras.... The 4 Hikvision work fine.. I have seen one of those get disconnected in the log but it seems that it connects back up. The two Foscam cameras will connect up when SS is first started.. then they later disconnect with the log reporting:

    Error communicating with the network device "Garage". 4.1.3,70900,800 Failed to obtain video frame from network device. The operation timed out.

    While the Hikvision cameras can generate this error they will seem to reconnect on their own if the network or whatever issue caused the error recovers. The the two cameras using the Foscam.h264 profile will not recover. It's like SS will attempt to reconnect at some point with the Hikvision cameras but not the Foscam units.

    Just restarting SS will then let the Foscam units come back online for some period of time. I've been seeing this in 4.1.1 and 4.1.2 as well. It seems to have improved some... but once the Foscam units are dropped they only seem to reconnect by restarting SS.

    Just to see if I could duplicate this... If I log into a Hikvision camera and reboot it then SS will detect when it is back up and reconnect to the camera. I get variable levels of reconnect with the other units.

    I also went in and changed the profile that the Foscam units were using from Foscam.h264 to ONVIF but still see the same issue.
  • Please could you both try version 4.1.4, released today (use the "Check for Update" option in the File menu in SecuritySpy) and let me know if these connection issues are improved. Thanks.
  • Installed and will monitor. 24 hours or less always has been the timeframe for disconnecting issue to appear.
  • Ben, the problem is fixed. Thank you!
  • Disregard, still disconnections. All worked well for 2 hours, now constant disconnections. Moving back to 4.1.2.
  • I have the same disconnect issue with both 4.13 and 4.14. I fave four Hikvision cameras with SS running on a Mac mini. The cameras reconnect after about 15 seconds.
  • Can you please describe the regularity of the disconnections? Are they seemingly at random, or do they occur at regular intervals? Many IP cameras will disconnect after a set time, and to prevent this SecuritySpy sends a "keep-alive" message to keep them streaming. If there is something wrong with this keep-alive message, then the disconnections should be very regular (e.g. every minute or every two minutes), however if the disconnections are random then this indicates a different problem.
  • Well so far I'm very happy with 4.1.4. I looked at the log and there were a couple of disconnects but these are wireless cameras that have the issue of being dropped. At least now with 4.1.4 it seems that SS does retry and reconnect. It's not a constant drop that I'm seeing. Once in awhile.. the problem before was that if SS dropped connection to the Foscam units that it would never attempt to reestablish the connection. It seems to correctly do so now with 4.1.4

    I did some tweaking on cameras frame rates and bit rates and then would reboot the cameras. I found that when I did that to one of the Foscam units that after I made some of the configuration changes ( not all were intelligent ones either ) that SS did not reconnect to that camera until I restarted it. But once I have a good connection at startup and don't mess with camera frame or bit rates that if the connection gets dropped due to network or other issues that 4.1.4 is now reconnecting and it doesn't seem to take it that long to do so...

    It might be interesting to see if the others having these issues are also WiFi cameras or hardwired and what kind of frame rates they are trying to push to SS.
  • Two of four Foscams freezing in 4.1.3, which is how I ended up at this thread. Will try 4.1.4.
  • Hi zroger73, if 4.1.4 doesn't fix it for you, please could you try SecuritySpy 4.1.1 and SecuritySpy 4.1.2 and let me know if you see the same problem or not. If we can narrow this down to a particular version it will be much easier to investigate.

    Also, please could you describe what you mean by "freezing"? Does the camera disconnect? Does it eventually reconnect?
  • Mine are constantly disconnecting and reconnecting with 4.1.3 and 4.1.4. Doesn't happen ever on 4.1.2

    On the main "Cameras" page, I'll just get disconnect notices for all cameras consistently, they'll reconnect, then a few seconds later, disconnect again, this happens non-stop once it starts happening. It happens within 10 minutes on 4.1.3, but on 4.1.4 took around 2 hours to begin happening (once it started it was constant). I have all Amcrest 841s - 6 total.
  • Once I tweaked the frame rates now on my two Foscam units I have had no drops on those cameras. Before I tweaked the frame and bit rates when they did drop they were connecting right back with 4.1.4. Working great with the companion apps on our iPhones, iPads, and Apple TV. Ben software has been so responsive with problems and good advice on these forums. This is the kind of software company I wish I had spent my career at.
  • @Ben, 4.1.4 didn't fix the issue. About 06:00 this morning, 4/12, I opened the SS app on my iPhone. 3 of 4 cameras were working fine. 1 camera contained a red "X" in the middle. The ("frozen") image showed a time stamp 06:02 on 4/11 (almost exactly 24 hours prior).

    I immediately went to my iMac to see what SS was doing. Again, 3 of 4 cameras were still live. The 1 camera that was "frozen" on my iPhone was also "frozen" in SS. There is NO error message or symbol appearing in SS 4.1.4 on my iMac. Curiously, the frozen image on the iMac for this camera shows a different camera time stamp of 13:34 on 4/12 - 5 hours later than the last image that the iPhone app shows for this camera.

    So, it does not appear that the camera(s) that are freezing in 4.1.3 and 4.1.4 will restart by themselves. I must close and re-open SS on my iMac.

    When I start multiplex on my iPhone, there is a "spinner" in the middle of the screen for about 30 seconds before the 4 cameras appear. No past image of the frozen camera appears - only a red "X".

    I closed and re-opened SS in my iMac and immediately all 4 cameras started streaming live video again on both my iMac and iPhone. Since I'm not constantly checking my cameras on my computer or phone, I don't know exactly when this happens, but the recorded video appears to have stopped at the 13:34 on 4/11 for the current, frozen camera. I suppose the reason the iPhone app shows this camera to have frozen at 06:02 on 4/11 is because that's the last time I opened the app and it's displaying the last image it received, so the 06:02 time is probably not significant since I have recorded video during and after that time.

    I appreciate all you do, but this is becoming an exercise in frustration. I need this to "just work" and it seems like I've had nothing but problems since upgrading to 4.1.2. Per the thread below that is now closed, I suppose I will revert to 4.0.10, which seems to be one of the last versions that was rock solid for me.

    http://www.bensoftware.com/forum/discussion/2038/fi9821w-v2-video-stutters-like-max-headroom#Item_14
  • Hi @zroger73 thanks for the information, what you describe is quite odd - either the stream coming into SecuritySpy is active and you should see normal video, or it has stopped, in which case SecuritySpy should detect this and close and reopen the stream. So what you are describing sounds like a bug, though it's not one we have seen ourselves and not one that has been reported by other users.

    It would really help to know exactly when this problem started. You said you see the problem in 4.1.2 - could you please try version 4.1.1 (link in my comment above). If you see the problem in 4.1.2 but not 4.1.1, I can compare the source code and see what changed and it will really help to track this down. Between 4.0.10 and 4.1.2 there have been significant changes, so this will be much more difficult to do.

    Thanks.
  • Hi again @zroger73 could you please also try the new beta version of SecuritySpy (currently 4.1.5b1), as it should detect the situation you describe and close and reconnect to the camera when it happens.
  • I think 4.1.5b1 has stopped the disconnections. No consistent disconnections since installing this beta.
  • For the record, I also tried this beta for the issues I'm experiencing as unfortunately it didn't fix it. Ben, I know we're looking at this separately, but I thought I'd give it a try anyway. My last working version is still 4.1.1.
  • Hi. I am also seeing the errors above. I get the x in the iOS app. But only for my two foscams. I am on travel now, so I can't do much about it, but just wanted to report back...
  • Seems I was too soon... the problems are still there with 4.1.1 but it just takes longer for them to show up. I'm going to install the beta link above and see if that solves it for me.
  • 4.1.5b1 is rock solid in my case. It's the most reliable version I've ever used of SS. Thanks
  • 4.1.5b1 has been stable for me for a couple of days so far. Unfortunately, the iPhone app now intermittently forces me to reconnect to the server - something it has never done before.
  • 4.1.5b1 is working for me with one exception. I installed it on a second Mac and it is configured to connect to the first mac with the license version of SS. Some of the cameras are not connecting but when I look at the iPhone app or on the licensed server all is fine. The cameras on the second mac are configured to get the feeds from the first mac via SS and are not connecting directly to the cameras.
  • The latest beta (4.1.5b3+) is all good for me now. Thank you Ben for investigating and fixing the issue.

    My Zmodo cam is working great again (apparently the Zmodo cams require a frequent "I'm alive" handshaking message, which was always very close to the minimum tolerance level). The cam is very happy again and most likely a far happier camper given the latest beta update. I'll be more than confident again in the SS product once 4.1.5 makes production.

    I much the appreciate the top class support on this and will continue to enjoy SecuritySpy and recommend to others.
  • I just installed 4.1.5b5 from 4.1.5b1 and all is good. Certainly the best support and software in the class. Couldn't be happier with the setup.
  • I was having the same disconnect issue. 4.1.5b4 is working for me for a few days now.
This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!