ONVIF Camera not connecting on 4.1.2/4.1.3
  • My Zmodo outdoor ONVIF camera has always worked well with SecuritySpy, but it's broken in 4.1.2 and 4.1.3. Rolling back to 4.1.1 fixes the issue.

    It will connect briefly, then go into a connecting... cycles which never manages to connect to the camera.

    I've also tried to remove the camera and set it up again.

    It's running on standard settings over HTTP. It's completely unrelated to iOS or the web service. The server itself is struggling to connect and maintain a connection.
  • When you say "standard settings over HTTP" - this is unusual because normally IP cameras send their video using RTSP. Under Preferences -> Cameras -> Device, make sure the Profile is set to ONVIF, and the Format is set to RTSP TCP.

    If that doesn't work, I think the best way to debug this (as we don't have any Zmodo cameras here to test with) would be if you are able put your camera online temporarily so that we can connect to it from here and do some testing - is this OK with you? To do this you will have to set up the port forwarding settings on your router to forward incoming connections to the camera on port 80, 554, and the ONVIF port (if it's not 80) and then email us your public IP address (or DDNS name, which can be set up in SecuritySpy's Web Server Setup window). Let me know if you need more information about how to set this up.
  • I meant the web server wrt HTTP. Yes the camera is using RTSP. I've tried all the options for this with the same result.

    I can do the camera port forwarding tomorrow. Currently it's explicitly blocked since I'm not keen on the Chinese manufacturers having access to the live stream ;)

  • Email sent.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!